Back to overview
Downtime

Update:

Apr 26 at 07:07pm BST
Affected services
dumbidiot.xyz
links.dumbidiot.xyz
blog.dumbidiot.xyz

Created
Apr 26 at 07:07pm BST

I know the issue, and why its caused. Will be back up within the day.