Back to overview
Downtime
Wow!
Apr 26 at 12:12pm BST
Affected services
dumbidiot.xyz
links.dumbidiot.xyz
blog.dumbidiot.xyz
Created
Apr 26 at 12:12pm BST
Everythings down!
Affected services
Created
Apr 26 at 12:12pm BST
Everythings down!
Affected services